# Which steps needs to be performed when any update done on ServiceNow entities are not getting synchr

### Description

This behavior is applicable when any update done on ServiceNow entities are not getting synchronized to the other end system.

### Cause

The possible reason could be: Audit is not enabled for the entities that are being synchronized.

### Solution

ServiceNow tracks incident, change, and problem history in the `sys_audit` table.\
Enabling auditing tracks the creation and update of audited records.

Audit must be enabled on the entity table (not on its import set table, but on the actual entity table like `incident`, `problem`, etc.).

To enable audit for a table, please refer [Enabling audit for a table](/opstech-docs/7.223/connectors/servicenow.md#turn-on-auditing-history-for-a-table).


---

# Agent Instructions: Querying This Documentation

If you need additional information that is not directly available in this page, you can query the documentation dynamically by asking a question.

Perform an HTTP GET request on the current page URL with the `ask` query parameter:

```
GET https://opstech.gitbook.io/opstech-docs/7.223/help-center-index/faqs/servicenow-faqs/update-not-getting-sync.md?ask=<question>
```

The question should be specific, self-contained, and written in natural language.
The response will contain a direct answer to the question and relevant excerpts and sources from the documentation.

Use this mechanism when the answer is not explicitly present in the current page, you need clarification or additional context, or you want to retrieve related documentation sections.
